Il est possible d’installer le RouterOs du système MikroTik sur un serveur Linux. Dans cet article, je vous montre comment vous pouvez effectuer ses manœuvres partir d’un script. Au cas où vous compter déployer cette solution en production, il est recommandé d’avoir au minimum deux (2) cartes réseau. Ainsi, vous n’aurez pas des difficultés pendant et après le déploiement.

Lire Aussi :Mikrotik: Configuration du serveur de temps NTP

Les Prérequis

  • Ram : 2 GB
  • Rom : 10 GB
  • OS : Ubuntu

Dans le votre terminal excuter la commande suivante

nano mikrotik_script.sh

Copier coller le script suivant. Fait Ctrl+O et Ctrl+X pour enregistrer le script

#!/bin/bash
#Téléchargement  et décompression du système RouterOs dans sa version 6.4
wget https://download.mikrotik.com/routeros/6.44.6/chr-6.44.6.img.zip -O chr.img.zip  && \
gunzip -c chr.img.zip > chr.img  && \
#Montage de fichier .image sur la racine ( \) du système Linux 
mount -o loop,offset=512 chr.img /mnt && \
#Paramétrage de l'interface réseau par défaut
ADDRESS=`ip addr show eth1 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY
/ip service disable telnet
#Initiation du l'utilisateur par défaut "root"
/user set 0 name=root password=xxxxxx
 " > /mnt/rw/autorun.scr && \
umount /mnt && \
echo u > /proc/sysrq-trigger && \
#Copie du fichier image vers la partition système 
dd if=chr.img bs=1024 of=/dev/xvda && \
echo "sync disk" && \
echo s > /proc/sysrq-trigger && \
#Temps de repos 
echo "Sleep 5 seconds" && \
#Temps de repos
sleep 5 && \
#Redémarrage du système
echo "Redémarrage en cour" && \
echo b > /proc/sysrq-trigger

Faite un snapshot de votre système de commence. Enfin de bien identifier la partition racine de votre système appliquer la commande suivante avant de commencer.

lsblk 

Appliquer cette commande et laisser la magie s’opérer.

bash mikrotik_script.sh

A lire également

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *